Bringup MangoH Red [wp76xx] Board interface on anther platform


I want to get Mangoh red [wp76xx] board interface on another platform other than PC.
Currently, i have tested the R12 release image on the MangoH red board with PC.

Now i want to get the interface up on another platform. Can you guide me on what all interfaces or changes needs to be done at the MangoH source end.

If not interacting with PC, what will be the platform to communicate with mangoh board?

Its a Qualcomm based chipset, which has Android running on it.

You can ssh via uart, usb, ethernet port.

I did try to ssh, but i dont get the port at all does not come up

do you have USB ECM driver on your platform?

Since its android i am hoping it supports.

You need to check dmesg and see if the usb ecm driver has been loaded.

When i connect the MangoH red board to customized board, i get the below dmesg :

<6>[ 1476.259022] cdc_ether 1-1.4:1.19 usb0: register ‘cdc_ether’ at usb-msm_hsusb_host-1.4, CDC Ethernet Device, b2:fb:8f:f9:c4:2f
<14>[ 1476.272717] avc: denied { set } for property=dhcp.usb0.result scontext=u:r:system_server:s0 tcontext=u:object_r:radio_prop:s0 tclass=property_service
<11>[ 1476.273972] init: no such service ‘dhcpcd_usb0:-f /system/etc/dhcpcd/dhcpcd.conf -h android-e6d87b06dbbba3ff usb0’

Is there something that needs to be in the dhcpcd.conf file ?

No idea, you should consult your platform vendor.
Maybe you can just do “ifconfig usb0”

Ok here are few steps we tried.

On the MangoH red board : [ All steps go through - No errors ]
iptables -t nat -A POSTROUTING --out-interface rmnet_data0 -j MASQUERADE
iptables -A FORWARD -o ecm0 -i rmnet_data0 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i ecm0 -o rmnet_data0 -j ACCEPT

iptables -t nat -A POSTROUTING --out-interface rmnet_data0 -j MASQUERADE
iptables -A FORWARD -o bridge0 -i rmnet_data0 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i bridge0 -o rmnet_data0 -j ACCEPT

echo 1 > /proc/sys/net/ipv4/ip_forward

On the customized hardware running Android :
ifconfig usb0

I am able to ping

But when tried to telnet the address no response.

You might also set the following to shut down the firewall on module:
iptables -I INPUT -j ACCEPT

After shutting down the firewall, i get connection refused from my custom board.

root@kite:/ # telnet
telnet: can’t connect to remote host ( Connection refused

|root@kite:/ # dmesg
<3>[ 682.171854] wlan: [1044:E :HDP] hdd_tx_rx_pkt_cnt_stat_timer_handler: Disable split scan
root@kite:/ # ping

Maybe you can again do “ifconfig usb0” on module

Tried doing that but no luck.

Should there be some telnetd running on the MangoH board ?>

You can verify by trying on pc first

ok so when i connect to the PC and boot MangoH red board for the first time i get the IP After sometime it looses the ip.

which one loses the IP?
PC or module?
If PC loses the IP, you can type “sudo ifconfig usb0”
If module loses the IP, you can type “ifconfig ecm0”

The PC loses the ip. The interface is also not usb0 but enp0s29u1u4i19.

so “sudo ifconfig enp0s29u1u4i19” command worked for some time like a min or 2 but after that PC loses the IP.

Can this be issue as it is not coming up as usb0 ?

you need to check dmesg.
I guess the network manager will change the name of usb0 to enp0s29u1u4i19