Brand new WP7603 working, reboot and inaccessible via ssh


#1

Hello,

We received some new WP7603’s recently and have begun working with them. Everything worked to start, we were able to connect to our Windows laptop and flash the wifi firmware using the tutorial here: https://github.com/mangOH/mangOH/wiki/mangOH-Red-mt7697-WiFi , and the MediaTek wifi worked using wifiWebAp. We were able to ssh and control the device from Ubuntu and Mac.

I rebooted the device using “reboot”, and since then the WP76 has become totally inaccessible. We cannot get an ip address from our Linux or Mac machines. We have tried the whole 9 yards, it seems as if the board is in a state

Our first thought is that this issue was encountered before with some old WP7603’s, where we were unable to ssh into them. So I thought that maybe the device reverted to an earlier firmware version. I tried installing release 7 and release 8 to no avail:

We cannot flash the firware with the Windows machine using the CF3 USB module, let alone connect to it, with the error:

Flashing Image
Awaiting Adapter…
Enabling Selective Suspend…
Firmware download failed.

Primary Error code: 82 - Failed in checking modem mode
Secondary Error code: 0 - Not applicable
Device error code 0x0 - Unknown device error code"

Powering with the Console port, we can flash the firmware, but I would imagine that the error above is indicative of some other problem, and even with the firmware flash we are still unable to connect via ssh. Minicom through the console port works for ~15 seconds before the board freezes and we are forced to reboot.

As the mangoh Red documentation says here: https://mangoh.io/uploaded-documents/Reference/mangOH%20Red/Discover/Getting%20Started/41110479_mangOH_Red_GettingStartedWinCLI_r3.pdf , we have the dipswitches set to 1,3,5,8.

A full list of actions that occurred on the board were just the AT commands from this video: https://www.youtube.com/watch?v=KDO835vo1Lg&feature=player_embedded, /sbin/ifup wlan1 and /sbin/ifdown/wlan1

What could be the issue here?


#2

Try putting dip switch 7 in the up position and then reset the board before trying to install release 8. Once it starts flashing the image, put dip switch 7 back in the down position. I don’t know what the problem your devices has encountered is though.

Maybe you could capture the output of running `dmesg from the console port before you try to revert to release 8.


#3

This is exactly the problem I’m facing. I tried as you suggested with the dip switch. That allowed me to update the firmware, however, I am still unable to ping the module.

I have included a screenshot of the dmesg.


#4

@curtiswj4770 @dfrey we had to restore the board with https://source.sierrawireless.com/resources/airprime/software/swiflash/ to get it back working. No idea what the issue was. If it bricks again I’ll report back


#5

I had the same issue with my module and i’ve found that if I remove the file “/etc/dnsmasq.d/dnsmasq.wlan1.conf” and reboot it, i’m able to get an IP from the Network adapter (CF3 USB).

You can achive this by putting the DIP switch 6 to the OFF position and opening a serial linux console (USB Console with a 115200 baud rate).

Hope it will help !


mangOH Red lost 192.168.2.2 IP & MT7697 Setup
#6

Kim,

Thank you very much! That worked. /etc/dnsmasq.d/dnsmasq.wlan.conf was a dead symlink, removing it solved our issue.


#7

Great, you’re welcome !