Bluetooth on mangOH Red

hi!
I followed instructions on https://github.com/mangOH/mangOH/wiki/Bluetooth-WL18xx-driver-for-mangOH to build kernel
(I used sources from http://downloads.sierrawireless.com/AirPrime/WP77xx/Release9.1/Legato-Dist-Source-mdm9x06-SWI9X06Y_02.18.05.00.tar.bz2)

as result I got 'yocto_wp77xx.4k.cwe file with size of 27M. Then I used Windows Developer Studio menu “generate custom Device Image”

it produced 71Mb .spk file.

Then I used Developer Studio “open Legato recover Wizard” and choose generated .spk

It gave no error (I did not touch Switch 7 on board)

but after reboot when I compiled and build BluetoothUtil
I got

Jan 6 00:03:33 | avcDaemon[827]/avcDaemon T=main | assetData.c assetData_RegistrationUpdate() 1946 | unsupported function called.
Jan 6 00:03:33 | bt-init.sh[1997] | | modprobe: module bluetooth not found in modules.dep
Jan 6 00:03:34 | bt-init.sh[1997] | | modprobe: module rfcomm not found in modules.dep
Jan 6 00:03:35 | bt-init.sh[1997] | | modprobe: module hidp not found in modules.dep
Jan 6 00:03:36 | bt-init.sh[1997] | | modprobe: module bnep not found in modules.dep
*Jan 6 00:03:38 | bt-init.sh[1997] | | /legato/systems/current/apps/bluetoothUtil/read-only/bin/bt-init.sh: *
*Jan 6 00:03:38 | bt-init.sh[1997] | | line 27: *
Jan 6 00:03:38 | bt-init.sh[1997] | | mux: not found

seems nothing was flashed.
Beside it I had opened custom port in iptables, and I expected that would be closed because it would overwritten with default iptables config. But port still opened after flashing.

please help! what did I wrong ?

btw, may be somebody have compiled firmware for WP7702 with enabled Bluetooth driver support which can be used with WL18 IoT extension card ?

logs after updating

FDT version: 1.0.1702.1
Awaiting suitable port or adapter …
Switching to boot & hold mode …
Disabling selective suspend …
Awaiting port removal …
Awaiting download port …
Switching to streaming mode …
Downloading images …
Writing image -
Flashing image -
Enabling selective suspend …
Awaiting adapter …
Checking update status …
Enabling selective suspend …
Firmware image download succeeded.
Final Firmware update succeeded.

Preexisting images information:

  •    Current:*
    
  •            Firmware:*
    
  •                    ImageId: 001.028_001*
    
  •                    BuildId: 02.16.06.00_GENERIC*
    
  •            Configuration:*
    
  •                    ImageId: 001.028_001*
    
  •                    BuildId: 02.16.06.00_GENERIC*
    

Final images information:

  •    Current:*
    
  •            Firmware:*
    
  •                    ImageId: 001.028_001*
    
  •                    BuildId: 02.16.06.00_GENERIC*
    
  •            Configuration:*
    
  •                    ImageId: 001.028_001*
    
  •                    BuildId: 02.16.06.00_GENERIC*
    

OEM PRI: 9907365 001.004

IMEI: 352653090105859

Total time elapsed: 107500 ms.

Time to switch to boot mode: 19438 ms.

Images downloaded:

  •    Image ID: 001.028_001*
    
  •    Build ID: 02.16.06.00_GENERIC*
    
  •            write time: 28671 ms*
    
  •            additional flash time: 13875 ms*
    

Time to reset to application mode: 41297 ms.

Press Enter to continue …
------------------
run bluetoothUtil after flash
PWD is: /legato/systems/current/appsWriteable/bluetoothUtil
Jan 6 00:17:34 | bt-init.sh[1883] | | modprobe: module hci_uart not found in modules.dep
Jan 6 00:17:35 | bt-init.sh[1883] | | modprobe: module bluetooth not found in modules.dep
Jan 6 00:17:36 | modemDaemon[867]/le_pa T=main | pa_sim_qmi.c MapSimState() 879 | More than one application 2
Jan 6 00:17:36 | bt-init.sh[1883] | | modprobe: module rfcomm not found in modules.dep
Jan 6 00:17:37 | bt-init.sh[1883] | | modprobe: module hidp not found in modules.dep
Jan 6 00:17:38 | bt-init.sh[1883] | | modprobe: module bnep not found in modules.dep
Jan 6 00:17:39 | modemDaemon[867]/le_pa T=main | pa_sim_qmi.c MapSimState() 879 | More than one application 2
*Jan 6 00:17:40 | bt-init.sh[1883] | | /legato/systems/current/apps/bluetoothUtil/read-only/bin/bt-init.sh: *
*Jan 6 00:17:40 | bt-init.sh[1883] | | line 27: *
Jan 6 00:17:40 | bt-init.sh[1883] | | mux: not found
*Jan 6 00:17:40 | bt-init.sh[1883] | | *
*Jan 6 00:17:40 | bt-init.sh[1883] | | /legato/systems/current/apps/bluetoothUtil/read-only/bin/bt-init.sh: *
*Jan 6 00:17:40 | bt-init.sh[1883] | | line 28: *
Jan 6 00:17:40 | bt-init.sh[1883] | | mux: not found
Jan 6 00:17:40 | bt-init.sh[1883] | |