Bluetooth mangoH yellow launch

the link shows that you need to check " dmesg | grep Blue"

Bluetooth isn’t going to be active until you’re running an application. A simple example:

root@swi-mdm9x28-wp:~# bluetoothctl
Agent registered
[CHG] Controller 3C:E1:A1:E8:B6:E1 Pairable: yes
[bluetooth]# 

Now I run bluetoothctl on an Ubuntu system:

paul@paul-ThinkCentre-M72e:~$ bluetoothctl
Agent registered
[bluetooth]# info 3C:E1:A1:E8:B6:E1
Device 3C:E1:A1:E8:B6:E1 (public)
	Name: BlueZ 5.52
	Alias: BlueZ 5.52
	Paired: no
	Trusted: no
	Blocked: no
	Connected: no
	LegacyPairing: no
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
	UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
	UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
	Modalias: usb:v1D6Bp0246d0534
[bluetooth]#

The Ubuntu Bluetooth sees the mangOH Bluetooth

Could you tell me where can I find some examples of app developed using BlueZ and Dbus to send message with another device (if possible) please?

bluetoothServices which can be found in https://github.com/mangOH/BluetoothServices . I used this as a model to implement the nRF Transparent UART service. I think you should be able to find a smartphone app from Nordic RF which can connect with it as is.

Thanks I will try it

I have this message when trying to connect to bluetooth after command ‘power on’, can you help me?

"no default controller available "

You mean you’re running bluetoothctl? Works for me:

root@swi-mdm9x28-wp:~# bluetoothctl
Agent registered
[CHG] Controller 3C:E1:A1:E8:B6:E1 Pairable: yes
[bluetooth]# power on
Changing power on succeeded
[CHG] Controller 3C:E1:A1:E8:B6:E1 Powered: yes
[bluetooth]# exit             
root@swi-mdm9x28-wp:~# cm info
Device:                        WP7702
IMEI:                          352653090190778
IMEISV:                        4
FSN:                           4L931585051610
Firmware Version:              SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
Bootloader Version:            SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
MCU Version:                   002.013
PRI Part Number (PN):          9909138
PRI Revision:                  001.001 
Carrier PRI Name:              SIERRA
Carrier PRI Revision:          001.027_000
SKU:                           1104405
Last Reset Cause:              Power Down
Resets Count:                  Expected: 379	Unexpected: 1
root@swi-mdm9x28-wp:~# 

It works after restarting my computing… strange. I managed to pair mangoh to smartphone but I get an error while trying to connect to my smartphone device :
image

Do you have any idea of what could be wrong? Then I still struggle to find my mangoh on nrF connect application but you might not know…

Then could you bring me clarifications of these points:

  • Where do I have to work : in my “leaf-data” folder or in my “mangoh” folder that both were created after installation.
  • is it possible to work with python? The only requirement is to use Legato standard of coding , right?

Thanks,

I looks like not all functions in bluetoothctl work on the yellow. The connect function is classic Bluetooth and it does not appear to work.

But my BLE application does work.

Regarding building bluetoothServices (which is BLE), I put it in ~/myWorkspace/mangOH/apps and added the app name to yellow.sdef in ~/myWorkspace/mangOH. Then when I do make yellow_wp77xx it gets built with all the other apps.

The gatttool utility which is on Ubuntu systems is useful in communicating with a BLE application.

Regarding python, you have Python 2.7.15 at the command line and can run scripts, that’s about all I know. There is a lot more discussion on Python on the forum.

OK and what is the bluez version? can we use mango with any version of bluez or is it only 5.48 as shown in this procedure

The default snap install looks out of date. There is a note at the bottom of the page saying a later version is available. I am using BlueZ 5.50 on Ubuntu which I downloaded. According to my post above the mangOH is running BlueZ 5.52.

paul@paul-ThinkCentre-M72e:~$ sudo snap find bluez
Name                 Version  Publisher     Notes  Summary
bluez                5.48-1   canonical✓    -      Bluez for Ubuntu
ofono                1.17-1   canonical✓    -      Mobile telephony daemon
bluez-tests          1        canonical✓    -      Set of utilities that are not production ready yet help in testing
bluetooth-autostart  1.1      maumx2        -      Simple snap to autostart bluetooth at boot
thingy52             1.0      anonymouse67  -      Compact multi-sensor BLE prototyping platform
bluetooth-6lowpand   0.1      wielgosm      -      BLE 6LoWPAN commissioning
paul@paul-ThinkCentre-M72e:~$ sudo snap info bluez
name:      bluez
summary:   Bluez for Ubuntu
publisher: Canonical✓
store-url: https://snapcraft.io/bluez
contact:   https://code.launchpad.net/~snappy-hwe-team/snappy-hwe-snaps/+git/bluez
license:   unset
description: |
  no description
commands:
  - bluez.bluetoothctl
  - bluez.btattach
  - bluez.btmgmt
  - bluez.btmon
  - bluez.hciattach
  - bluez.hciconfig
  - bluez.hcidump
  - bluez.hcitool
  - bluez.meshctl
  - bluez.obexctl
  - bluez.sdptool
services:
  bluez:      simple, enabled, inactive
  bluez.obex: simple, enabled, inactive
snap-id:      JmzJi9kQvHUWddZ32PDJpBRXUpGRxvNS
tracking:     latest/stable
refresh-date: 2020-07-13
channels:
  latest/stable:    5.48-1     2020-07-13 (229) 4MB -
  latest/candidate: 5.48-1     2020-07-08 (229) 4MB -
  latest/beta:      5.48-1     2020-07-03 (229) 4MB -
  latest/edge:      5.48-2-dev 2020-07-10 (240) 4MB -
  20/stable:        5.53-2     2020-11-13 (252) 5MB -
  20/candidate:     5.53-2     2020-11-12 (252) 5MB -
  20/beta:          5.53-2     2020-11-12 (252) 5MB -
  20/edge:          5.53-2     2020-11-12 (252) 5MB -
installed:          5.48-1                (229) 4MB -
paul@paul-ThinkCentre-M72e:~$ 

Thanks. I will try to change the version of bluez. Now I have 5.50 and I would like to change to 5.52. Can you tell me how to do this please? I tried to follow one process based on internet and I made it in mangoh folder but it haven’t changed the version…

If you’re talking about the version of Bluez on the mangOH you should be able to update it to 5.52 by loading the latest firmware. I have never tried updating it any other way.

Hi,
I am still wondering why I do not have the 5.52 version. I followed the guide for installation of the leaf environment… maybe it is because I chose "$ leaf setup -p mangOH-yellow-wp77xx_0.2.3 ". I should have chosen another version you thing? This was not the latest version

I’m simply using firmware revision 0.6.0 as downloaded from here:

https://mangoh.io/mangoh-yellow-resources-software

I downloaded the last firmware 0.6.0 but my version bluez is still 5.50 and not 5.52. Anyway, I am not sure it is the origin of my problem.

Concerning your previous message :“I looks like not all functions in bluetoothctl work on the yellow. The connect function is classic Bluetooth and it does not appear to work.” Do you mean it is normal that it doesn’t work but the BLE apps can work even if devices are not connected? Could you try to make a connect to one your device please and let me know if it works?

BLE doesn’t connect the way Bluetooth Classic does, it’s a different protocol in many respects. So connect working (or not working) on one does not apply to the other. Using bluetoothctl I get different errors trying to connect from either side:

Ubuntu->mangOH
[bluetooth]# connect 3C:E1:A1:E8:B6:E1
Attempting to connect to 3C:E1:A1:E8:B6:E1
Failed to connect: org.bluez.Error.Failed
[bluetooth]# 

mangoh->Ubuntu
[bluetooth]# connect 5C:F3:70:98:69:EC
Device 5C:F3:70:98:69:EC not available
[bluetooth]# 

Here is gatttool on Ubuntu connecting to my application on the mangOH yellow using BLE:

paul@paul-ThinkCentre-M72e:~$ sudo gatttool -b 3C:E1:A1:E8:B6:E1 -I
[3C:E1:A1:E8:B6:E1][LE]> connect
Attempting to connect to 3C:E1:A1:E8:B6:E1
Connection successful
[3C:E1:A1:E8:B6:E1][LE]> primary
attr handle: 0x0001, end grp handle: 0x0005 uuid: 00001800-0000-1000-8000-00805f9b34fb
attr handle: 0x0006, end grp handle: 0x000d uuid: 00001801-0000-1000-8000-00805f9b34fb
attr handle: 0x000e, end grp handle: 0x0013 uuid: 6e400001-b5a3-f393-e0a9-e50e24dcca9e
[3C:E1:A1:E8:B6:E1][LE]> char-desc
handle: 0x0001, uuid: 00002800-0000-1000-8000-00805f9b34fb
handle: 0x0002, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x0003, uuid: 00002a00-0000-1000-8000-00805f9b34fb
handle: 0x0004, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x0005, uuid: 00002a01-0000-1000-8000-00805f9b34fb
handle: 0x0006, uuid: 00002800-0000-1000-8000-00805f9b34fb
handle: 0x0007, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x0008, uuid: 00002a05-0000-1000-8000-00805f9b34fb
handle: 0x0009, uuid: 00002902-0000-1000-8000-00805f9b34fb
handle: 0x000a, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x000b, uuid: 00002b29-0000-1000-8000-00805f9b34fb
handle: 0x000c, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x000d, uuid: 00002b2a-0000-1000-8000-00805f9b34fb
handle: 0x000e, uuid: 00002800-0000-1000-8000-00805f9b34fb
handle: 0x000f, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x0010, uuid: 6e400003-b5a3-f393-e0a9-e50e24dcca9e
handle: 0x0011, uuid: 00002902-0000-1000-8000-00805f9b34fb
handle: 0x0012, uuid: 00002803-0000-1000-8000-00805f9b34fb
handle: 0x0013, uuid: 6e400002-b5a3-f393-e0a9-e50e24dcca9e
[3C:E1:A1:E8:B6:E1][LE]> 

btgatt-client connecting to same application:

paul@paul-ThinkCentre-M72e:~/bluez-5.50/tools$ ./btgatt-client -d 3C:E1:A1:E8:B6:E1
Connecting to device... Done
[GATT client]# Service Added - UUID: 00001800-0000-1000-8000-00805f9b34fb start: 0x0001 end: 0x0005
[GATT client]# Service Added - UUID: 00001801-0000-1000-8000-00805f9b34fb start: 0x0006 end: 0x000d
[GATT client]# Service Added - UUID: 6e400001-b5a3-f393-e0a9-e50e24dcca9e start: 0x000e end: 0x0013
[GATT client]# GATT discovery procedures complete
[GATT client]# 
service - start: 0x0001, end: 0x0005, type: primary, uuid: 00001800-0000-1000-8000-00805f9b34fb
	  charac - start: 0x0002, value: 0x0003, props: 0x02, ext_props: 0x0000, uuid: 00002a00-0000-1000-8000-00805f9b34fb
	  charac - start: 0x0004, value: 0x0005, props: 0x02, ext_props: 0x0000, uuid: 00002a01-0000-1000-8000-00805f9b34fb

service - start: 0x0006, end: 0x000d, type: primary, uuid: 00001801-0000-1000-8000-00805f9b34fb
	  charac - start: 0x0007, value: 0x0008, props: 0x20, ext_props: 0x0000, uuid: 00002a05-0000-1000-8000-00805f9b34fb
		  descr - handle: 0x0009, uuid: 00002902-0000-1000-8000-00805f9b34fb
	  charac - start: 0x000a, value: 0x000b, props: 0x0a, ext_props: 0x0000, uuid: 00002b29-0000-1000-8000-00805f9b34fb
	  charac - start: 0x000c, value: 0x000d, props: 0x02, ext_props: 0x0000, uuid: 00002b2a-0000-1000-8000-00805f9b34fb

service - start: 0x000e, end: 0x0013, type: primary, uuid: 6e400001-b5a3-f393-e0a9-e50e24dcca9e
	  charac - start: 0x000f, value: 0x0010, props: 0x10, ext_props: 0x0000, uuid: 6e400003-b5a3-f393-e0a9-e50e24dcca9e
		  descr - handle: 0x0011, uuid: 00002902-0000-1000-8000-00805f9b34fb
	  charac - start: 0x0012, value: 0x0013, props: 0x08, ext_props: 0x0000, uuid: 6e400002-b5a3-f393-e0a9-e50e24dcca9e

[GATT client]# 

Well, thanks. I will try. Also, my application bluetoothServices is stopped and I cannot start it. I guess it is normal?