AT!MAPUART strange behavior


#1

Hi,

I’m trying to set the MangOH Green with “AT!MAPUART=1,1”. However, when I run the command to check if it worked the result is “AT!MAPUART: 17,16”, looking at the developers datasheet this is not even possible, can someone give me a hint if the command is working and what I’m doing wrong?

Regards,
Daniel


#2

what module are you using and fw revision?
run cm info on the device


#3

Hi Asyal, thanks for the feedback.

Device: WP7702
IMEI: 352653090001751
IMEISV: 2
FSN: VU735370470101
Firmware Version: SWI9X06Y_02.16.04.00 019853 jenkins 2018/05/15 19:28:37
Bootloader Version: SWI9X06Y_02.16.04.00 019853 jenkins 2018/05/15 19:28:37
MCU Version: 002.009
PRI Part Number (PN): 9907365
PRI Revision: 001.001
Carrier PRI Name: GENERIC
Carrier PRI Revision: 001.021_000
SKU: 1103530
Last Reset Cause: Power Down
Resets Count: Expected: 79 Unexpected: 15


#4

Can you print your direct output for the AT command?


#5

Sure, I’m attaching it. However, I got it wrong, the output is still strange but not as I said. Can you explain these outputs?

AT


#6

Hi @fefer, that looks good to me. As per AT command spec (https://source.sierrawireless.com/resources/airprime/software/airprime_wpx5xx_wp76xx_wp77xx_at_command_reference/):

Usage:
• Execution: AT!MAPUART=<service>[,<uart>]
Response: OK
Purpose: Map the specfiied <service> to the specified <uart> (if no <uart> is
specified, UART1 is used).
• Query: AT!MAPUART?
Response: !MAPUART: <service (UART1)>, <service (UART2)>
OK
Purpose: Report the current mappings for both UARTs

(edit: And by “looks good” I mean it matches the spec :). The asymmetry of the get/set parameters on this one trips me up too.)


#7

Oh, gotcha, thanks a lot!! Yes, it was written but it’s a bit tricky. Another thing about this command that I didn’t get, I saw that I can change both MUX by hardware (using the dipswitch) or by software (using MAPUART). So, how does this works?


#8

Sorry, I don’t follow the MUX/dipswitch comment. Can you point me to the document you’re referring to? I don’t think there are any hardware mechanisms to override the MAPUART configuration, but maybe there is some conflicting documentation.

Ryan


#9

Sure, Developers guide page 27 and 28, there is a table of how you can change UART settings, it says by hardware/software method. Bellow is the table:


#10

The MUX allows you to direct UART1 to either IoT0 or IoT1 slot.
The AT commands allow you set the desired state of the UART (linux etc.)


#11

Thanks for the clarifying it. The MUX hardware settings allow setting to the Arduino too, right? So, If I’m right and I want a connection of Arduino to the Linux as a bridge connecting to CF3 module I need dipswitch 6 set to OFF and AT!MAPUART set to 17,1, right?


#12

Have you tried this tutorial: https://mangoh.io/mangoh-green-arduino

@Mirac might be able to help you with that.


#13

Hi Asyal,

I’ve been trying it, but I’m struggling to find some of the files, like the “Airvantage.zip”. I’ll contact @Mirac to check if he can help me solve some of my problems :slight_smile:


#14

Hi fefer,

Can you please try this tutorial and see if it works:

4119370_mangOH Green Tutorial - Arduino to AirVantage_r1.pdf (989.6 KB)

Let me know if you have further questions.

Thanks,
Mirac


#15

AT!MAPUART= 17 ,1 to set UART0 (HS0) to Customer Linux Application.
AT!MAPUART= 16 ,2 to set UART1 (HSL1) to Linux Console.
AT!MAPUART?

Result is:
AT!MAPUART: 17,16

The output shows the status of the two serial ports, HS0 followed by HSL1
17 = ttyHS0 linux application,
16 = ttyHSL1 linux console.

Service to map to UART:
0: UART disabled
1: AT Command service
2: Diagnostic Message service
3: Reserved
4: NMEA service
5-15: Reserved
16: Linux Console
17: Customer Linux application


#16

Hi @Mirac,

Thanks for your answer. I´ve seen this tutorial before, but it seems like it´s made for WP8548, while my MangOH contains the WP7702 and a small part of the tutorial uses files specific to WP8548, is it safe to work with those files? Do I need to download similar files but for WP7702? If yes, where should I find them?

Furthemore, by the image it seems like you use an Arduino extension of AirVantage, where should I find the files to install this extension?

Best,
Daniel


#17

Thank you @AndrewMawdsley, I got it. My question now is how to connect the modem with the Arduino. Asyal and Mirac pointed to really good docs. However, there are still a few gaps in my mind on how to connect them.


#18

Hi Daniel,

If you’re talking about compiling mangOH platform, you don’t have to download new files, just use “make green_wp77xx” instrad of “make wp85” specified in the document (note that do not replace “wp77xx” with the actual module number i.e. “wp7702” etc. )

The arduino bridge files can be found here: https://github.com/mangOH/ArduinoBridge

Thanks,
Mirac