Anyone using the Talon WiFi card?


Is anyone successfully using the Talon Mirage IoT card, or another WL18xx - based device?

Someone posted earlier this week on the FX30 forum having trouble with this card on the 13.1 release:

I was able to use the card on Mangoh Green with the release 11 firmware, but releases 12 and higher throw the same error that opoei reports on the FX30.


Have u tried release 14


Yes, I tried each release listed here from 11 through 14


Did you try release 14 on a mangOH board? I tried the same and didnt have this issue.
what exactly is your failure with a release 14 on a mangOH board?


hmmm. I re-flashed and wiped the user partition on my Mangoh Green + WP8548 a few times with Release 14 in the process of getting logs.

Sometimes after I flash an image the WiFi card can enumerate, other times it fails. Success or failure is sticky between reflashes. The failures correlate with enumeration errors in the background from usb 1-1 and msm_hsic_host1. Let me know if there’s any more information I should collect

release13_fail.txt (7.0 KB)
release13_ok.txt (8.6 KB)
release14_fail.txt (9.0 KB)
release14_ok.txt (61.1 KB)


are you using USB or power adapter to power up the board?


12V / 2A power adapter


We have applied a patch that fixes the timing issue that we see that we believe caused this issue. Could you please update your mangoh green system,? Do the following:

git pull
git submodule update

rebuild the mangoh green system and apply to your unit.


okay, I see the commit on github, but I’m I’m not set up yet to build mangoh images… the instructions on don’t quite work for me out of the box, so far due to legato-swi not installing in /opt/swi. I’ll take another look on Monday