Airvantage autostart issue


Dear Community,

We are evaluating the WP with mango board and having an issue to autostart the Airvantage service. (fw: SWI9X15Y_07.11.22.00, Legato version 16.10.1) It works fine when started manually sends statuses according to the setting but after reboot the service simply does not connect to Airvantage.

Current configuration:
+WDSC: 0,0
+WDSC: 1,1 //it should be 0 by default according to the AT manual
+WDSC: 2,1 //it should be 0 by default according to the AT manual
+WDSC: 3,1 //only changed this value from 15 --> 1, (does not work with 15 either)
+WDSC: 4,0


+WDSG: 0,3
+WDSG: 1,0


Airvantage login starts only manually with command:


+WDSI: 4

+WDSI: 6

+WDSI: 23,1

Does anybody have an idea or do i miss something?



Hi Tom,

When you restart your unit, there needs to be an app that tells the airvantageservice to connect to Airvantage.

Can you install the following app:

on your platform and run it? this should allow your system to connect to AV on bootup. Note that the app is manual start, you may want to change that.



Hi Ashish,

Thank you for clearing that up!
You mean this app?

It wasn’t evident for me from the AT documentation. I think you should be able to configure the airvantage agent with only at commands without an extra app/configuration as it is with non legato modules (if i remember correctly) It makes me confused!

Thanks again for the answer,


Hi Tom,

Yes, that’s the correct git location :slight_smile:

There could be a way to do it using AT commands besides the the legato app. I’ll dig into it, ask internally and let you know.



Can you try:

AT+WDSC Device service configuration

3 Polling mode
The embedded module will initiate a connection to the Device Services server according to the defined timer

For = 3; value in range = 0 – 525600 in min
0 Polling mode is deactivated

Not 100% sure whether this works but let me know if it does.


Hi Tom,

When you try at+wdss command, the module is connected to AirVantage.
You may do at+wdss=1,0 in order to stop the connection. You may see:
+WDSI: 8 (for success)
at+wdsc=3,1 is a bit low. I prefer you set at+wdsc=3,2 (2 minutes).

at+wdsc command works. Do you have some +WDSI notification if you do nothing each 2 minutes?


Hello Asya & Rjacolinl,

experience was that it worked till the reset but after repower the module forgot the setting but i will double check it again a try out the AirVantageControl app and i will let you know!



Hello All,

Strange things, the module is keeping now the settings after reset so at+wdsc=3,x works. I haven’t done anything differently, or at least i don’t know about it.
Thanks for the help!

BTW, We would like to update the application with Airvantage.
I have tried to update the app several times but i always get update failure. Should i open an other topic? Here is the log:

I have received this sometimes:
avcDaemon[511]/avcAppUpdate T=main | avcAppUpdate.c Object9FieldActivityHandler() 1481 | Duplicate attempt detected.
But usually i get these messages:
avcDaemon[517]/avcDaemon T=main | avcServer.c QueryUninstall() 717 | Automatically accepting uninstall
Mar 12 19:05:54 | avcDaemon[517]/avcDaemon T=main | assetData.c assetData_DeleteInstance() 3160 | Deleting instance tmCore/0/0
Mar 12 19:05:54 | avcDaemon[517]/avcDaemon T=main | assetData.c assetData_DeleteInstance() 3160 | Deleting instance tmCore/1/0

/* Here i See that my application sends some debug messages, so obviously delete was not successful*/

/* After 60 seconds */
avcDaemon[517]/le_pa_avc T=unknown | pa_avc_qmi.c ProcessAvmsState() 358 | Received User App update
Mar 12 19:06:54 | avcDaemon[517]/le_pa_avc T=unknown | pa_avc_qmi.c ProcessAvmsState() 406 | Download failed. Avms update_complete_status 500.

If somebody has an idea please share it…



After some restart the Mangoh board does not connect to the Airvantage again. I have also tested it with a “brand” new Mangoh with different Sim card and it shows the same behaviour.
+WDSC: 0,0
+WDSC: 1,0
+WDSC: 2,0
+WDSC: 3,10
+WDSC: 4,0
And the application update is not working either. What is he meaning of the Customer ID in the firmware? (1102816 by me)
Isn’t it possible that there is a problem with avcService? I presume it is checking these AT settings.
I will try out the AirVantage control application later but the avcService should be as robust as possible…



I tried the AirVantage control application and it works. I used the le_avc_SetPollingTimer() function and it seems to do the job. Only using AT commands the avcDaeom sometimes “forgets” to connect to the airvantage after reboot. I still have issue updating the application, i opened a new topic for it here:

Thanks for the help!