Adding MySql CLI tool to the Mangoh

Does anyone know if there is a way to add the command line tool to the mangoh? I have sqlite3 working through API commands, but ideally I would like a way to setup a way to interface directly with my database file instead of having my app acting as a man-in-the-middle.

have you tried to add the tool in following file and rebuild yocto cwe?


IMAGE_INSTALL_append = " sqlite"

Thanks for the reply. I have not tried that and I can’t find that directory. Where should it be located?

I’m also not familiar with yocto. I’ve done some digging and it seems like legato is based off of yocto, so is there something that I need to install or should I be able to make these changes “out of the box”?

Yes, you can rebuild the yocto image

Ok, how do I rebuild the yocto image? and where is it located on my system?

I found the “” file you refferred to, on github, but where should I download that file to? or do I need the entire directory?


yes, you need to download the whole package which is quite big

Just type “make” to build the yocto

Ok, does it matter where the directory is placed in my computer? and how do I install it to my mangoh?

you can download the yocto cwe to your module

Ok, I must be missing something. I downloaded the entire “meta-swi” directory and placed it alongside my mangOH and leaf-data directories on my computer. When i try to execute “make” inside the “meta-swi” directory, it cant find any make files.

I’ve searched for make files and they exist, but there are a number of them in different sub-directories, which one should i run?

should be in the yocto folder, just come out from the meta-swi folder

The link for the linux distro source on the sierra wireless website is currently broken and the legatoproject github doesnt have a “yocto” folder, only the meta-swi and meta-swi-extras.

Is there somewhere else i should be looking?

Are you using wp76 module?

no, i’m using the wp7702 on the mangoh yellow

Did you use “leaf getsrc swi-linux” to download?

I did not try that, but when I do, i get this error. I’ve tried tracking it down and installing various packages but it seems to be sending me in circles.

You might see here

I have “leaf getsrc swi-linux” running in my leaf shell without errors now, but I cant find any new files after?

What files do you get now?

BTW, you can also get my file here.
sqlite3.rar (1.4 MB)

Inside, there are and sqlite3.

You can copy to /tmp folder of module and type the following:

mkdir /tmp/tmp_usr_lib;mkdir /tmp/tmp_usr_lib_wr;
mount -t overlay overlay /usr/lib -o lowerdir=/usr/lib,upperdir=/tmp/tmp_usr_lib,workdir=/tmp/tmp_usr_lib_wr;
ln -s /tmp/ /usr/lib/
chmod 777 /tmp/sqlite3

root@swi-mdm9x28-wp:~# /tmp/sqlite3
SQLite version 3.22.0 2018-01-22 18:45:57
Enter ".help" for usage hints.
Connected to a transient in-memory database.
Use ".open FILENAME" to reopen on a persistent database.
sqlite> sqlite> ^Z[2]+  Stopped                    /tmp/sqlite3

I still don’t get anything from leaf getsrc swi-linux.

I appreciate the sqlite file, however, I’m more focussed on trying to get mysql up and running in order to have a client/server relationship with the database. Sorry about the confusion.

Also, I’m not sure where the “tmp” folder that you’re referring to is located?

Tmp folder is /tmp folder in module