About PSM mode on mangOH Yellow

Hi all, I purchased a mangOH Yellow and want to test its PSM functions. I found this post and use it as guidance: Using PSM (Power Saving Mode) with Legato - Legato Forum

The problem is that when I set the value using the method in this post, the mangOH Yellow will not enter PSM after the active time I set, even the “status” already changed to “8 - PSM is enabled.”

I am using an AT&T LTE-M sim. I can confirm that the active time and PSM time I set are valid since they’re already tested on some other LTE-M/NB-IoT testbeds under the same network.

Has anyone successfully setup the PSM on this testbed? Any help will be much appreciated.

Can you post the full AT command log?

Thanks for your reply. I have tried to the following commands in the ssh terminal to set the PSM:

T3324 value in seconds $ echo 30 > /sys/module/swimcu_pm/psm/active_time

T3412 value in seconds $ echo 3600 > /sys/module/swimcu_pm/psm/psm_time

Enable PSM $ echo 5 > /sys/module/swimcu_pm/psm/enable

It seems that the logs of AT command are not showing up in the ssh terminal and CON serial port, where can I get them?

You can use “microcom /dev/ttyAT” to enter AT command

I just tried some commands but I found at!powerwake and at!powermode not working on my side. I can set the AT+CPSMS successfully, but still, it’s not going into PSM…

AT!POWERWAKE=1,108000
ERROR
at
OK
AT!POWERWAKE=?
ERROR
AT!POWERWAKE?
ERROR
AT!POWERMODE?
ERROR
AT+CPSMS?
+CPSMS:1,“00111110”,“00001000”

I don’t see such problem on my WP76:

at!powermode?
!POWERMODE: No request, status=9-PSM disabled

OK
ati3
Manufacturer: Sierra Wireless, Incorporated
Model: WP7609
Revision: SWI9X07Y_02.37.03.00 73df45 jenkins 2020/04/08 10:59:14
IMEI: 359782080100373
IMEI SV: 14
FSN: WA803370311610
+GCAP: +CGSM

OK
at!powerwake?
!POWERWAKE:
ULPM TIMER: 14400
PSM TIMER: 14400,ACTIVE TIMER:20,SYNC: 2

OK

I reflashed the firmware and finally can set the timers and power mode. Here are the logs:
at!powermode?
!POWERMODE: mode=2-PSM_ONLY, status=8-PSM enabled

OK
at!powerwake?
!POWERWAKE:
ULPM TIMER: 3600
PSM TIMER: 3600,ACTIVE TIMER:30,SYNC: 3

OK
at+cpsms?
+CPSMS:1,“00000110”,“00001111”

But I still feel confused about this PSM status. I couldn’t find any ‘sign’ of PSM mode even waited for a very long time. I can still send AT commands and get responses, the PDP context is also activated and the testbed can access the internet.

On other testbeds, they would just go completely power off when entered PSM. Did the testbed already enter PSM? If not, do I need to disconnect the USB and CON and use the battery?

I rechecked the log and I think I found the problem.
After I set up the PSM timer and active timer through AT!POWERWAKE (e.g AT!POWERWAKE=1,3600,30) and activate the PSM using AT!POWERMODE=2, the modem will try to process the timer setting, and there will be an error
" swimcu_active_time_attr_store: invalid input -1",
and the active timer will be reset to “2880”(maybe a default value). So it seems that the active timer I set is recognized as “invalid input”. But the value has no problem on other testbeds with the same SIM. It’s weird that CPSMS is correct, which means the modem did translation correctly (from integer to GPRS timer form).

Probably a firmware bug? Couldn’t find any information about this error code…

AT command guide says the timeout value must be greater than the configuration in PSM mode.
Seems you have set a longer timing in AT+CPSMS.