mangOH red, ping 192.168.2.2 does not work


#1

I am trying to get started with the brand-new mangoOH red board following instructions from
http://mangoh.io/uploaded-documents/Reference/mangOH%20Red/Discover/Getting%20Started/41110481_mangOH_Red_GettingStarted_LinCLI_r3.pdf
:

[1013.216061] usb 1-2: New USB device found, idVendor=1199, idProduct=68c0
[ 1013.216070] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1013.216076] usb 1-2: Product: WP7504
[ 1013.216082] usb 1-2: Manufacturer: Sierra Wireless, Incorporated

[ 1013.283238] usbcore: registered new interface driver usbserial
[ 1013.283279] usbcore: registered new interface driver usbserial_generic
[ 1013.283311] usbserial: USB Serial support registered for generic
[ 1013.293888] usbcore: registered new interface driver qcserial
[ 1013.293929] usbserial: USB Serial support registered for Qualcomm USB modem
[ 1013.296960] qcserial 1-2:1.0: Qualcomm USB modem converter detected
[ 1013.303609] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB0
[ 1013.306730] qcserial 1-2:1.2: Qualcomm USB modem converter detected
[ 1013.308236] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB1
[ 1013.310130] qcserial 1-2:1.3: Qualcomm USB modem converter detected
[ 1013.310809] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB2
[ 1013.341438] usbcore: registered new interface driver cdc_wdm
[ 1013.360375] cdc_ether 1-2:1.19 usb0: register ‘cdc_ether’ at usb-0000:00:06.0-2, CDC Ethernet Device, 8e:49:a1:e7:1c:4c
[ 1013.360398] usbcore: registered new interface driver cdc_ether
[ 1013.366434] qmi_wwan 1-2:1.8: cdc-wdm0: USB WDM device
[ 1013.366756] qmi_wwan 1-2:1.8 wwan0: register ‘qmi_wwan’ at usb-0000:00:06.0-2, WWAN/QMI device, ca:d9:26:89:3c:45
[ 1013.366832] usbcore: registered new interface driver qmi_wwan
[ 1013.371279] qmi_wwan 1-2:1.8 wwp0s6u2i8: renamed from wwan0
[ 1013.384507] cdc_ether 1-2:1.19 enp0s6u2i19: renamed from usb0
[ 1013.414989] IPv6: ADDRCONF(NETDEV_UP): enp0s6u2i19: link is not ready
[ 1013.415852] cdc_ether 1-2:1.19 enp0s6u2i19: kevent 12 may have been dropped

  • modemmanager is not installed.
    sudo apt-get remove -y modemmanager
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package ‘modemmanager’ is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 62 not upgraded.

  • ping 192.168.2.2 does not work.

Also, I tried on the real Linux machine.The final results are same.
However, when I start “ping 192.168.2.2” and then connect a board to USB port I can see correct pings within approx 10 seconds.
On a virtual machine it is difficult because it is necessary to connect the USB device on the fly when it appears.
Again, the results are identical on both Linux machines ( virtual and real).
It seems the board appears correct. Then, Linux renames the network interfaces.

I have disabled the Predictable Network Interface Names
ln -s /dev/null /etc/systemd/network/99-default.link

Now, both interfaces appear non-renamed

usb0 Link encap:Ethernet HWaddr 8e:49:a1:e7:1c:4c
inet6 addr: fe80::5153:b5ef:9c95:7b21/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:652 dropped:0 overruns:0 frame:0
TX packets:0 errors:12 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wwan0 Link encap:Ethernet HWaddr ca:d9:26:89:3c:45
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

But the link does not work

Would you please help me get started ?


#2

Hi,

Which Linux distribution are you using? Also, please provide a copy of /etc/network/interfaces.


#3

Hi,
I am using
Legato Virtual Machine from http://mangoh.io/mangoh-red-resources-getting-started which is running under VirtualBox.

mangoh@mangoh-virtualbox:~$ cat /etc/*release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"
NAME="Ubuntu"
VERSION="16.04.3 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.3 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

cat /etc/network/interfaces

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

auto enp0s3
iface enp0s3 inet dhcp


#4

Make sure you give the virtual machine access to that USB device.
Settings>USB
- add filter
- select device from list


#5

In VirtualBox, go to the VM settings (when it’s not turned on), then click “Network” and “Advanced” and make sure that the “Cable Connected” checkbox is checked. I have seen this be a problem for some people, but I’m not sure why it only affects some people.


#6

Note, the mangOH board is detected over USB connection. And even a network interface is created. But it does not work.


#7

When you say it does not work, what do you mean?

Before you can ssh in to it over the network connection you need to edit the file /etc/iptables/rules.v4
If you want to be able to ping/ssh over eth0, add these lines:

# Allow SSH, PING and DHCP over eth0 interface
-A INPUT -i eth0 -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -i eth0 -p icmp -m icmp --icmp-type 8 -j ACCEPT
-I INPUT -i eth0 -p udp --dport 67:68 --sport 67:68 -j ACCEPT


#8

usb0 network interface does not work
when I try to establish the connection from Legato Virtual Machine (http://mangoh.io/mangoh-red-resources-getting-started) which is running under VirtualBox.

usb0 interface works when I connect from Win10 or VMware Ubuntu virtual machine.


#9

Have you given the virtual machine access to the USB device as described in my first post?


#10

yes, the virtual machine can access the USB device


#11

I have had the same issues, and now I tend to just SSH in to the ethernet port rather than the USB.
There is a fix posted here that may work for you.

The most important thing is to make sure you aren’t running the USB through a hub, as that causes the most issues.