$LEGATO_ROOT empty


#1

Hi,
I just started with the Mangoh Green. Installed the latest firmware and VM. I’ve updated the VM using apt-get. Now the manual tells me to cd into $LEGATO_ROOT/apps/sample/helloWorld, however $LEGATO_ROOT is not set. What should
I do.


#2

You first need to set an environmental variable to LEGATO_ROOT. (Set LEGATO_ROOT to the directory where you installed legato-xx.yy.z).

For setting up environmental variable,

open .profile in your editor. Bash command:
'<EDITOR>EDITOR> ~/.profile',
where EDITOR can be any editor such as gedit or vim.
Add,
export LEGATO_ROOT=<path to the directory where you have installed legato>

Save and exit.

To check if LEGATO_ROOT is set or not, use bash command:
printenv LEGATO_ROOT


#3

Thanks, that worked!


#4

Welcome. Glad to know that you got it working! :slight_smile: