Issues Installing Legato and Using CLI


#1

Hello,

I am having issues with my first use of the MangOH green and WP8548. I am trying to run through the application note http://mangoh.io/docs/4118961_LinCLI%20mangOH%20Green%20Fundamentals_r4.pdf , and install Legato and configure the window for Legato use, but get the error below in the process:

support@GW-Ubuntu:~/legato$ uname -a
Linux GW-Ubuntu 3.19.0-33-generic #38~14.04.1-Ubuntu SMP Fri Nov 6 18:17:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

support@GW-Ubuntu:~$ cd ~/legato
support@GW-Ubuntu:~/legato$ ./legato-spm --installed --update-link
Refreshing installed packages
========== Install pending packages ==========
Found 0 update site
========== Installed packages ==========
Legato Application Framework (16.7.0.201609081601)
GCC cross compiler Toolchain (1.7.3.fw_SWI9X15Y_07110900-wp85-wp750x-native-x86_64-201608171142)
Legato Device Image for WP85/WP75 (7.11.9.00.wpX5-201609121138)
Legato Recovery Tooling for Linux (4.0.0.linux-201607191626)
Legato for WP85/WP75 (16.7.0.wp85-wp75-native-x86_64-201609121201)
5 packages installed

Update latest link to SDK version 16.7.0.wp85-wp75-native-x86_64-201609121201
support@GW-Ubuntu:~/legato$ ource ~/legato/packages/legato.sdk.latest/resources/configlegatoenv
No command ‘ource’ found, did you mean:
Command ‘gource’ from package ‘gource’ (universe)
ource: command not found
support@GW-Ubuntu:~/legato$ source ~/legato/packages/legato.sdk.latest/resources/configlegatoenv
Modules: wp85, wp750x
SDK Path: /home/support/legato/packages/legato.sdk.16.7.0.wp85-wp75-native-x86_64-201609121201
Framework Path: /home/support/legato/packages/legato.framework.16.7.0.201609081601 - $LEGATO_ROOT
Toolchain Path: /home/support/legato/packages/legato.toolchain.1.7.3.fw_SWI9X15Y_07110900-wp85-wp750x-native-x86_64-201608171142 - $WP85_TOOLCHAIN_DIR $WP750X_TOOLCHAIN_DIR
Device Image Path: /home/support/legato/packages/legato.device.image.7.11.9.00.wpX5-201609121138 - $WPX5_DEVICE_IMAGE
Recovery tools Path: /home/support/legato/packages/legato.recovery.4.0.0.linux-201607191626 - $WPX5_RECOVERY
No toolchain found for target ‘ar7’.
Unable to find compatible cross-build toolchain for target ‘ar7’.
No toolchain found for target ‘ar86’.
Unable to find compatible cross-build toolchain for target ‘ar86’.
/home/support/legato
support@GW-Ubuntu:~/legato$ source ~/legato/packages/legato.sdk.latest/resources/configlegatoenv
Modules: wp85, wp750x
SDK Path: /home/support/legato/packages/legato.sdk.16.7.0.wp85-wp75-native-x86_64-201609121201
Framework Path: /home/support/legato/packages/legato.framework.16.7.0.201609081601 - $LEGATO_ROOT
Toolchain Path: /home/support/legato/packages/legato.toolchain.1.7.3.fw_SWI9X15Y_07110900-wp85-wp750x-native-x86_64-201608171142 - $WP85_TOOLCHAIN_DIR $WP750X_TOOLCHAIN_DIR
Device Image Path: /home/support/legato/packages/legato.device.image.7.11.9.00.wpX5-201609121138 - $WPX5_DEVICE_IMAGE
Recovery tools Path: /home/support/legato/packages/legato.recovery.4.0.0.linux-201607191626 - $WPX5_RECOVERY
No toolchain found for target ‘ar7’.
Unable to find compatible cross-build toolchain for target ‘ar7’.
No toolchain found for target ‘ar86’.
Unable to find compatible cross-build toolchain for target ‘ar86’.

Has anyone seen this before?

Thanks,

Brandon


#2

I don’t actually see a problem (other than the fact that you typed ource instead of source the first time. It is expected that the toolchains for ar7 and ar86 are not present. You don’t need them for using the wp85 in a mangOH board.


#3

Hi David,

Thanks! I will try running through the commands after, and see if I run into any actual issues.

Regards,

[cid:image019.png@01D0E4DB.789D2640]http://www.getwirelessllc.com/

Brandon Hammer
Technical Resources | GetWireless • Connecting the Internet of Things


#4

Hello i am having the same issue while trying to use Legato CLI, when i run :
~/legato$ source ~/legato/packages/legato.sdk.latest/resources/configlegatoenv

I got the errors:

No toolchain found for target ‘ar7’.
Unable to find compatible cross-build toolchain for target ‘ar7’.
No toolchain found for target ‘ar86’.
Unable to find compatible cross-build toolchain for target ‘ar86’

Could anyone help me please ?


#5

Hi Mima,

I mentioned previously that those errors are actually acceptable because ar7 and ar86 are not relevant to mangOH. I think it’s obviously a bit confusing because it looks like it’s an error.


#6

Thank you @dfrey dfrey, you all right. It’s only a warning that has to be ignored :wink: