CAN IoT Card driver


#21

Progress update :

echo 13 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio13/direction
echo 1 > /sys/class/gpio/gpio13/value

pin SPI1_CLK / SPI1_MISO / SPI1_MOSI follow the state on GPIO13 on WP76…

SPI bus seems don’t work. mcp2515 is not probed.

Asyal any idea ?


#22

@Francis.duhaut I’ll build this on Friday and get back to you with the right steps.


#23

ok thanks :slight_smile:


#24

@asyal any progress on the CAN for the WP76 ?


#25

I ran into the same issues you did and will work on resolving it next week.


#26

Thank’s a lot for your help.


#27
  1. Reflash new image with CAN driver module support to the target board
    FDT command: fdt yocto_wp85.cwe

When I run it I get: command not found: fdt
What do I need?


#28

Use :
cfglegato
fwupdate download yocto_wp85.cwe 192.168.2.2


#29

Thanks, Francis, I got one step closer but I am a bit confused about next one. When should I remove the card and how? I tried different ways but
echo 2 > /sys/class/gpio/export
gives me
sh: write error: Device or resource busy