Airvantage Application update failes with code 500 from avcDaemon


#1

Dear community,

I have spent too much time for this issue but i have no idea how to do anything differently. I always get the following error message: “avcDaemon[505]/le_pa_avc T=unknown | pa_avc_qmi.c ProcessAvmsState() 406 | Download failed. Avms update_complete_status 500.” It is some kind of timeout but i don’t know why.

Here is the complete log:

Mar 20 16:00:46 | lwm2mCtrlDaemon[4638]/lwm2mControl T=main | lwm2mControl.c StatusHandler() 128 | Air Vantage agent reported update status: SESSION_STARTED
Mar 20 16:00:46 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | lwm2mCtrlDaemon[4638]/lwm2mControl T=main | lwm2mControl.c StatusHandler() 128 | Air Vantage agent reported update status: UNINSTALL_PENDING
Mar 20 16:00:47 | lwm2mCtrlDaemon[4638]/lwm2mControl T=main | lwm2mControl.c StatusHandler() 152 | Accepting APPLICATION uninstall.
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | assetData.c assetData_DeleteInstance() 3160 | Deleting instance sample10_airvantageControl/0/0
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | assetData.c assetData_DeleteInstance() 3160 | Deleting instance sample10_airvantageControl/1/0
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:00:47 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:01:07 | lwm2mCtrlDaemon[4638]/lwm2mControl T=main | lwm2mControl.c StatusHandler() 128 | Air Vantage agent reported update status: NO_UPDATE
Mar 20 16:01:43 | avcDaemon[504]/le_pa_avc T=unknown | pa_avc_qmi.c ProcessAvmsState() 358 | Received User App update
Mar 20 16:01:43 | avcDaemon[504]/le_pa_avc T=unknown | pa_avc_qmi.c ProcessAvmsState() 406 | Download failed. Avms update_complete_status 500.
Mar 20 16:01:43 | lwm2mCtrlDaemon[4638]/lwm2mControl T=main | lwm2mControl.c StatusHandler() 128 | Air Vantage agent reported update status: DOWNLOAD_FAILED
Mar 20 16:01:44 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData
Mar 20 16:01:44 | avcDaemon[504]/avcDaemon T=main | lwm2m.c OperationHandler() 143 | Defaulting to lwm2m namespace for assetData

It is simply the modified airvantageControl sample application. I have also tried with an older version of legato with the same result. I have a feeling that i am missing a simple step. Could someone give me a hint what i am doing wrong?

thanks,
tom


Airvantage autostart issue
#2

Hi, I think the “NO_UPDATE” message would be the first clue. What exactly have you tried to do from Air Vantage, uninstall an app, release a new app to a device or upgrade an existing app ? For an upgrade, the upgraded zip package has to be available in air vantage.

The status handler messages only reflect what Air Vantage is telling it, so any problems are likely to originate there.


#3

Hello Happytuna,

Thanks for your answer.

I succesfully released the applications with zip files, i tested with several applications/Sim cards/mangoh green devices. I can test it later with FX30. I also used the av-pack manually, no luck. Uninstall application works. I have also seen problems with the avcDaemon configurations (AT commands) and a few days ago during the night the avcDaemon simply forget to connect to the airvantage again with (lv_avc_SetPollingTimer()) maybe invoking only le_avc_StartSession() works i didn’t try it. My opinion is that avcDaemon has some issues or it simply doesn’t like me! :slight_smile:
We ended up implementing remote update with FTP which works fine.
I must say apart from this issue ( and the I2c bus instability on Mangoh Green) we are really satisfied with Legato&Mangoh.
Hope somebody has an idea, i am pretty sure it is a setting, configuration issues somewhere as others have no problems with updates with Airvantage.

Cheers,
tom


#4

Can you provide the output of cm info and legato version? I want to verify that all of the software components are compatible.


#5

Hi David,
cm info:
Device: WP8548
IMEI: 359377060013298
FSN: LL540300051303
Firmware: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Bootloader: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
priIdPn: 9905383
priIdRev: 01.07
skuId: 1102816

legato:
16.10.1_a6a25fbda05738774857dccb9fd76a99_modified

BR
tom


#6

Dear Community,

I have found out in the firmware note 13.1 that my issue is a known issue and it is because that my mobile network does not support NITZ messages and the modem’s time is not correct see:

QTI9X1555-
1009
FOTA/SOTA fails if the
attached network doesn’t
authorize the update of the
local time
When the NITZ information is not provided by
the attached network, the installation FW
/Bundle fails as the TLS certificate requires a
valid date.
As a workaround, the current date may be
manually set via AT!TIME, e.g.
at!time=2017,01,31,00,00,00
OR via the kernel console:
echo -e
"at!time=2017,01,31,00,00,00\r" |
microcom -t500 /dev/ttyAT

I am not quite sure why this time is used when it is in the 80s and there is a linux time which could be correct.
Another thing what i have noticed that if any app that binds to the avc service it can block the updates even if it does not subscribe to any handles. The default should be that it allows the updates and can request with APIs to block specific/all updates.

tom